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About this manual

Typographical This manual distinguishes between different types of
conventions information using the following conventions:

« Terms taken from the interface itself, such as commands,
appear in bold.

» Keys appear in small caps, for example: Press the sHiFT
key.

* Numbered lists indicate that there is a procedure to follow.
* When the conjunction -or- appears next to a paragraph, it

means there is the option of a different procedure for
carrying out a given task.

« When a menu command contains submenus, the menu
name, followed by the command to select, appears in bold.
Thus, “Go to File > Open” means go to the File menu, then
the Open command.

This symbol highlights important information on
& how a particular command or procedure works.

for optimizing tasks, speeding up commands, and

Following this symbol, you will find hints and tips
; other helpful information.
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CHAPTER 1

Introduction

Welcome!

TEKLYNX label design and integration software provides
an easy-to-use, user-friendly solution for printing bar code
labels and tags to meet compliance standards in any
industry.

What is this guide?

This guide provides information to help you understand
how to manage your labeling software in the context of an
enterprise environment.

Who should read this guide?

This Administrator’s Guide is for IT personnel (system
and network administrators) who are responsible for
managing the deployment of software applications,
specifically on the Microsoft Windows platform.
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Product description
Your product includes the following components:
» A CD for the installation
» Complete documentation
* A license agreement and registration card

* A protection key, either electronic (software key) or hard
key (dongle)

System requirements

The configuration required for the software to run properly is
the same as most applications running on Windows:

* One of the 32- or 64-bit Windows® operating Windows:
7, XP, Vista, Server 2003, or Server 2008.

» Computer with 1GB of free RAM (depending on the
system).

* A hard drive with at least 500 MB free disk space
(depending on the installation options).

* CPU: 2 Ghz minimum.
* Video card : DirectX 9 minimum.

* Administrator rights to the computer during the
installation procedure.

The ReleaseUS.html file contains the latest information
on the software. This information supersedes the
information contained in this manual.
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Installing the Software

Functional description

The network (multi-user) packages allow you to control
access to the labeling software licenses over the network.
Using this utility, you can have multiple users accessing the
label design software at the same time, from anywhere on
the network.

To use the network/multi-user version of your labeling
software, you must install the Network and Users Utilities
on the server or on a station that will serve as a server, then
install the labeling software on each workstation.

Installation of the Network and User Utilities
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= =\
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Figure 1 Network Configuration Installation.
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Installation procedure

Before you start

Network
Manager

Installing the
Network and
Users Utilities

Before you can install the software, the network
administrator must first define the structure of the network
for the group of users, specifically:

» Define the license server on which the Network and
Users Utilities and the dongle will be installed.

 Define the client workstations that will use the labeling
software.

The Network and Users Utilities let you define the network
configuration of your labeling software. Network Manager
includes:

» The License Manager (License Service)

* Network Settings Wizard, which helps you define the
network configuration.

* User Manager: The User Manager is installed with the
Network and Users Utilities so you can define access
rights to the labeling software in a network setting.

Before installing the labeling software on all the workstations
that will use it, you must first install the License Service utility
on the server to configure the network.

To install the Network and Users Utilities on the server:

1 Insert the CD in the appropriate drive.

The Installation window is displayed.

If the CD-ROM does not run automatically, go to Start >
Run, then type the letter of the CD-ROM drive, followed
by index.hta (for example, D:\index.hta).

2 Select Network and Users Utilities, which includes

License Manager and User Manager. Then, click the

Install button.

3 Follow the instructions on the screen.
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Configuration

5 Share the TKpongle folder with full control, using
TKDongle as the share name. The default access path
for this folder is C:\Documents and Settings\All
Users\ApplicationData\Teklynx\LicenseManagen\T
KDongle(for Vista the path is: C:\ProgramData\
Teklynx\LicenseManager\TKDongle) > right-click >
Properties > Sharing tab and Permissions button.

4lf you want to define settings for your network
configuration, start the Network Settings Wizard on the
server. If you do not modify the configuration, each
workstation will have its own settings.

For administrators:

' Users wanting Write Access to the Network

L J . . .

license must be given the rights by:

1. Sharing the TKDongle folder and authorizing
the user: C:\Documents and Settings\All
Users\Application Data\Teklynx\LicenseMan-
ager\TKDongle (Vista: C:\Program Data\Tekl-
ynx\LicenseManager\TKDongle) > Right-click >
Properties > Sharing tab and Permissions
button.

2. Give Write Access to the user on the Security
tab of the TKDongle properties

All the necessary tools to configure the network version are
available from the Network toolbar, and can be accessed
by going to Start>Programs>Teklynx>Network and
Users Utilities and selecting Network Toolbar.

The Network Settings Wizard helps you define the settings
for your network version.

1 To start the Network Settings Wizard, click on the icon.
2 Select a settings mode: Generic, By user or By station.

* Generic: All users will use the same settings on all
workstations. (user.ini).

» By user: Each user can access his or her own settings
on any workstation. (user name.ini).
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Starting the
License
Manager

Installing the
software on the
workstations

+ By station: Each workstation has its own settings
(station.ini).

3 Specify the location in which you want to store these
settings. If you want to share these settings between various
workstations, specify a network path accessible to all
workstations. (for example TKDongle).

4 Specify the location in which you want to store the shared
data (variables, lists, printing logfile, etc.). Be sure all users
have appropriate access on these folders.

To configure the User Manager

If you want to define network access rights for all users of
the labeling software, you must do so in the User Manager
(for more information, consult the User Manager help
system).

Click the User Manager icon |@| on the Network toolbar.

Before installing the labeling software on all workstations,
you must be sure the License Manager is started.

The License Manager was installed as a service called
SLicense. You do not need to manually start it. In fact,
SlLicense starts when the workstation is turned on and runs
as a background task as long as the workstation is on.

'. If you installed the Service License as software key
" |protected, you must activate the license before it will
start automatically.

To start the Service Controller
* Click the @ icon on the Network toolbar

_Or_
Double-click the sLicensecTrL.EXE file.

The labeling software must be installed on all the
workstations on which it will be used.

To install the software on a workstation
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1 Insert the CD for the installation in the appropriate drive.
The Installation window is displayed.

If the CD does not run automatically, go to Start >Run, then
type the letter of the CD drive, followed by index.hta (for
example, D:\index.hta).

2 Select the product to be installed, click the Install button,
and follow the instructions on the screen.

3 Start the labeling software. The Activation Wizard is
displayed. Click Try to launch the software. A message is
displayed to inform you that no dongle has been found. Click
Yes to start the software.

4 From the Tools menu, choose Network Administration.
5 Enable Use Network License.

6 Click Modify to select the server on which the License
Manager and dongle are installed.

_or_

Click Browse to automatically search for the server on
which the License Manager is installed.

If the network settings have already been configured, a
message asking if you want to use the current network
configuration is displayed.

7 If you want to modify or configure the network settings,
click the Network Settings Wizard button ﬁ.

8 Click OK.

9 Restart the program.

If the server is changed, you will have to update all
' of the workstations. In this case, start the labeling
e software and choose Tools > Network
Administration. Disable and re-enable the Use
Network License option.
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License protection

Hardware Key
protection

Your software can be protected using a software key (an
electronic code) or a hardware key (a dongle).

The dongle is a small electronic device that you plug into
your PC’s parallel or USB port before launching the
software. Without the hardware protection key, the program
will run in “evaluation” mode. You will not be able to save
your labels, “e” will be replaced with “x,” “0” with “5”, and
images will be crossed when printing.

The software key is an electronic code that is requested by
the Activation Wizard when you launch the software for the
first time or as long as you have not activated the software.

You must first install the software and then activate or
connect the protection key to your computer.

The protection key must be installed on the computer on
which the License Manager is installed. A single protection
key, pre-programmed with the number of licenses
purchased, is included with the network version of your
software.

The dongle must be installed before the License Manager
can be started.

If you have purchased a software with a dongle, you can
choose between a USB or parallel port dongle.

Connecting the parallel key

Parallel port'DB25 female connection
e [g a]  A—ll
¥‘_K&y

Figure 2 Connecting the dongle to the parallel port on your PC

= =
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port, simply plug it into the software protection key.
In this case, it might be necessary to turn the
printer on in order for the software protection key
to be recognized.

Q If you need to use a printer on the same parallel

Connecting the USB key

//“/9 use Porte® | '.
= !

Key

Figure 3 Connecting the dongle to the USB port of your PC

When you use a USB key and have multiple USB ports, it
does not matter which port you use. If you do not have an
available USB port, you can use a USB expander hub. USB
devices are hot-swappable, meaning you can plug and
unplug them at any time without restarting the PC.

Drivers can be installed while the application is running.
However, you must restart your labeling software for
the changes to take effect.

Error messages If you receive an error message when launching the

when launching software, please check the following items:

the software o L

» Administrative rights. You must have local administrative

rights on your PC for the key installation to work
properly. If you do not have these access rights, you will
see an error message when launching the software, and
you will have to manually install the drivers.

* Driver installation. If you had trouble during installation or
if you receive an error message when launching the
software, you will have to manually install the drivers.

* The key. If you receive an error message when launching
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Installing the
driver key
manually

Software key
protection

the software, check that the connected key works with
your software.

* Driver update. If you receive an error message when
launching the software, your driver may not be updated.

To update your driver, download the new version from
http://www.aladdin.com/support/hasp/enduser.aspx

To manually install the key driver:
1 Click Start, then click Run.

2 Enter C:\Program Files\Teklynx\Network\Tools\Dongle\,
then type the following command: \HaspDinst.exe -i

Itis recommended that you close your labeling software
and other applications before installing your driver.

Once you have installed the labeling software, the Activation
Wizard will be launched, taking you step-by-step through the
software key protection process.

To Activate the software key

1 In the Activation Wizard, select Activate, then click Next.
There are three possible activation methods: Online
activation, Activation from another computer, and

Offline activation.

2 Depending on the selected activation method, follow the
appropriate steps to complete the activation process.

If you are connected to the internet, the wizard will
automatically select activate online.

Online activation

1 Select Activate online.
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SMA account window is displayed. If you select | have a
SMA account, the SMA account information step appears.
If you select | do not have an SMA account, next step will
be User Registration and you will need to enter all user
data. A new SMA user account will be created automatically.

Some enterprise networks are protected by a proxy server.
In this case, there is an extra step which allows you to enter
the IP address and connect to the Internet.

2 Enter your information in the User Registration form.
Click on Next.

3 Enter the serial number and the password provided with
the product and click Next.

4 Click Finish.
Activate from another computer

1 Select Activate from another computer.

SMA account window is displayed. If you select | have a
SMA account, the SMA account information step appears.
If you select | do not have an SMA account, next step will
be User Registration and you will need to enter all user
data. A new SMA user account will be created automatically

2 Enter the serial number and the password provided with
the product and click Next.

3 Select the media to use for activation (USB key or external
hard disk) and click Next. Files for activation will be copied
into the selected media.

4 Unplug the media.

5 Plug this media into another computer connected to the
Internet.

6 Run USBWizard.exe (it can be found on the root of the
media). This will start the wizard.
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7 Select the license(s) to activate and click Next.

8 Input your information in the User Registration form.
Click Next.

A message will inform you that the activation information for
the selected license(s) has been successfully retrieved.

9 Unplug the media from this computer.

10 Plug this media into the computer where the software is
installed and run USBWizard.exe again (it can be found on
the root of the media).

11 The wizard will display the license that can be activated
on the computer where the software is installed.

12 Click Next.
13 Click Finish.

If any problems were encountered, a message will inform
you that the activation has failed and an error will be
displayed.

Activate offline

1 Select Activate offline.

SMA account window is displayed. If you select | have a
SMA account, the SMA account information step appears.
If you select | do not have an SMA account, next step will
be User Registration and you will need to enter all user
data. A new SMA user account will be created automatically

2 Select one of the three possible offline activation
procedures: Activate by email, Reset a pending email
activation (allows you to get a new serial number and
password in case of problems), Activate by phone.

Email activation

3 Enter your information in the User Registration form.
Click Next.
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4 Enter the serial number and the password provided
with the software and click Next.

5 Send the email created to activations@teklynx.com.
6 Click Exit to launch the software in trial mode.
7 When you receive the validation code and the

installation code, please start the software to launch the
wizard.

8 Select Continue a pending activation and click
Next.

9 Enter the validation code and the installation code
returned by email and click Next.

10 Click Finish.
Reset a pending email activation

This activation mode can be used if you have not sent the
email for activation or if you have lost your license. A new
serial number and password will be delivered to enable you
to proceed with the activation process.

Activate by phone

3 Call the contact displayed in the wizard depending on
your location.

4 You will be required to provide user registration
information over the phone. Please have your company
information available, along with the serial number,
password and user code.

5 Enter the validation code and the installation code
provided by phone and click Next.

6 Click Finish.
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Network Use

Managing users

License
Service
Controller

The License Manager is installed as a service. This service,
referred to as SLicense, is enabled automatically when the
server is turned on.

The License Service Controler module, named
SlLicenseCtrl.exe, is used to control how the service
functions and to change the standard behavior of the
License Manager. You can, for example:

« Start or stop the service

« Display the list of users connected to the labeling
software

Description of the License Service Controller window

« To start License Service Controller, click on the icon on the
Network toolbar.

Once started and the window is enabled, the License
Service Controller window is displayed as follows:
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4 License Service ==

Toolbar \LILI ol & 2]
— B

Indicator panel

License Service iz stopped. Click on the

Frame reserved for | "Start'" [»] buttan,
status or error
messages.
Uszers
i Uszers 1
List of users P i
connected to the gers 3
labelling software. Users 4
Uszers 5

Figure 1 Main Service Control window

The License Service Controller window displays the list of
users. This list permanently displays the login name of those
currently using the labeling software.
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The License Server Controller window toolbar contains the
following buttons:

ﬂ Stops the service.

| » | Starts the service.
@ Refreshes the display: The list of users may not
be updated in certain cases, such as if a

workstation crashes. To reset a workstation,
press CTRL+ALT+DEL.

% Accesses the Service Control Settings window.
_| This button is only available when the service is
stopped.

m Displays the About window. This window
e displays the version number of the program.

The Indicator Panel

The Indicator panel displays the current status of the
service.

Indicator = Red: The 'ndicator = Orange: |ndicator'= Green: The

service is stopped. The service is starting  ggrvice is enabled.
up.
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The Settings dialog box

To access the Settings window:

 Click El

The Settings window is displayed.

Settings E|

Licenze file path
|C:\Dncuments and SettingztAl Uszers\Application DatahTE .

Language [ Enable stopping when users
—————— are connected

g »

[IH =

Dansk

Deutsch 1] Foey part

eelting

E spafiol
Frangaiz o
Italiana w

Figure 2 Settings window

To change the settings

If SLicense.exe was not installed in the [DONGLE] folder, you
must specify the access path to the license file.

1 Enter the new access path to the license file, or click the
Browse button.

2 If you want to allow the service to be stopped while users
are still logged on, select the Enable stopping while users
are connected option.

3 If you want to change the display language of the License
Service Controller, select the desired language from the
Language list.

4 Click OK to update the changes.
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Maximum
number of users

Changing the behavior of the service

By default, the service is started automatically when the
workstation is turned on. However, you can change the
behavior of the service in the Services window in the
Windows Control Panel. For more information, refer to the
documentation supplied by Microsoft.

Changing the service startup type
1 Select SLicense from the list of services.
2 Click Startup.

3 Enable the desired startup type. SLicense is configured
to start automatically by default.

Selecting a user account
1 Select the user account in the Log on as field.

2 Type and confirm the password and click OK in the
Service window.

In case you installed the License Manager on a Windows®
workstation your network version is limited to a maximum
number of users. This means that a 10-user license allows
you to start 10 sessions of the Ilabeling software
simultaneously. If an eleventh user tries to log on, an error
message is displayed indicating that the maximum number
of users has been reached. He or she must wait until one of
the connected users logs off.

To increase the simultaneous connections, you have to
install the License Manager on a Windows® Server.

Troubleshooting
Two types of error messages can be displayed. The table

below lists possible problems and describes the
troubleshooting procedure.
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Protection key
not found

License
Manager cannot
create the
license file

- The key is not connected.

- The dongle is connected to the wrong
port (serial port, for example).

- A printer is connected to the dongle
and is switched off.

- The product has not been activated.

The license file could not be created in
the [TKDongle] folder. This may mean
that a user on the station on which
License Manager was started does not
have the access rights required to write
to this folder. The network administrator
must assign the required access rights
(read, write, delete, and modify, if
applicable).

Managing shared resources

Shared
document files

A document can only be opened by one user in read/write
mode. If the same document is opened by other users, it is
opened in read-only mode. This means that only the first
user can modify and save the document.

only mode.

Q Note: The document can be printed from read-

To provide security for the work of the group, the opening
mode for documents can be defined in the Options window
on the Document tab, by selecting the Open documents in
read only mode by default option.
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Shared data

Shared printing
logfile

Shared file
timeout period

The Network Settings Wizard is used to configure data
sharing for variables, lists of values, and the printing logdfile.

To share data, you must specify a path and folder on the
network in step 3 of the wizard.

If you selected the generic settings mode in the

Network Settings Wizard, the printing logfile (which is very
useful for tracking all print jobs) can be configured in the
printing logfile window.

To share the printing logfile with all workstations, you must
first generate the log file on one of the workstations.

To generate a printing logdfile
1 Go to Tools > Printing Logfile.

2 Enter the access path to the folder in which shared data
is saved and a file name for the printing logfile, then select a
text editor.

3 Enable your options on the Options tab. For more
information on the printing logdfile, refer to the online Help
system.

As with shared variables, if multiple users are working
on the same file, only one printing logfile is created and
it tracks all print jobs for each user. However, a user can
generate a personal file.

When a shared file, such as a file of shared variables, is
opened by a user, it cannot be accessed by other users.
Others users must wait until it becomes available before
editing it. After a timeout period (defined by you), a message
is displayed asking the user if he or she wants to continue
waiting or cancel the request.

To define the timeout period:
1 Go to Tools > Options.

2 Click the Others tab.
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Printing

3 Type a value in the Shared files access timeout period
(ms) field.

A flashing colored indicator indicates the status of the
current print job in the Print Status windows. This status is
only displayed if you display the Print window in the labeling
software.

» Green: The data is being printed.

» Orange: A user is currently using a shared resource
(printer or variable).

* Red: Error.
To display the print dialog box:
1 Go to Tools > Options and click the Printing tab.

2 Disable the Hide the Cancel Print dialog box option.



Network Use Chapter 3 - 21

Notes for the network administrator

This section describes folders on the server and
workstations, and the required access rights.

Folders on the server

During installation, the [TKDONGLE] folder is created. It is
important for each user to have read/write access to the
shared TKDONGLE folder.

Folders on the workstation

The table below describes each of the sub-folders of the
[comMmON] folder and the required access rights. The access
path to this folder is C:\Documents and Settings\All
Users\Application Data\Teklynx\

For Vista users, the path is: C:\Program Data\Teklynx\

[COMMON APP PATH] RWMC
TEKLYNX\LABELVIEW 9

[COMMON APP PATH]\ RWMC
TEKLYNX\LICENSEMANAGER

R=Read W=Write M=Modify C=Create

Users must be given, at minimum, read/write access to
all available folders in the default folders list (Tools >
Options > Default folders).
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